Third-party issue: DHL Express - Label announcement issues

Incident Report for Returnless

Resolved

This incident has been resolved.
Posted Apr 08, 2026 - 16:29 CEST

Investigating

We are currently investigating an issue preventing users from announcing DHL Express labels.
Posted Apr 08, 2026 - 13:37 CEST
This incident affected: Shipping integrations (DHL Express).