Third-party issue: [PostNL, QLS] - Label announcement issues

Incident Report for Returnless

Resolved

This incident has been resolved.
Posted Apr 09, 2026 - 13:53 CEST

Investigating

We are currently investigating this issue.
Posted Apr 09, 2026 - 13:25 CEST
This incident affected: Shipping integrations (PostNL, QLS).