Third-party issue: [DPD] - Label announcement issues

Incident Report for Returnless

Resolved

The incident has been resolved.
Posted Feb 26, 2026 - 13:31 CET

Investigating

We are currently investigating an issue preventing users from announcing labels.
Posted Feb 26, 2026 - 11:53 CET
This incident affected: Shipping integrations (DPD Benelux).